Microsoft Visual C++ 14.0 is required. Get it with "Microsoft Visual C++ Build Tools解决办法

最近在新的笔记本上安装package,使用pip install出现一长串错误:Microsoft Visual C++ 14.0 is required. Get it with “Microsoft Visual C++ Build Tools,解决方法特此做记录。

在这里没有使用MV C++工具去下载,而是通过该网站:https://www.lfd.uci.edu/~gohlke/pythonlibs/直接去寻找你所需的安装包。Tips:使用Ctrl+F快速搜索安装包名。下载.whl文件后,直接使用pip install yourpackage.whl安装即可。

需要注意的是安装过程中可能需要别的packages,这些packages如果也出现该错误:Microsoft Visual C++ 14.0 is required. Get it with “Microsoft Visual C++ Build Tools,那么还是通过那个网站去下载,手动安装。

点赞

发表评论

电子邮件地址不会被公开。 必填项已用*标注

3 × 3 =